Conta più se

samuele agnolin
  • 29 ottobre 2016
  • livello: intermedio   3 minuti
conta più se

La funzione CONTA.PIÙ.SE conta quante righe di un elenco soddisfano due o più condizioni da noi specificate. Quanti sono i clienti donna che abitano in Toscana? Quanti sono i prodotti venduti in Spagna nell’ultimo mese?

Come si scrive il conta più se? Ecco un esempio di funzione conta più se che scriveremo in uno dei tanti esempi pratici che trovi in questo tutorial excel sul conta più se:
=CONTA.PIÙ.SE(C9:C73;”rosso”;D9:D73;”sicilia”)

La funzione conta più se è l’evoluzione della funzione conta.se: quando dobbiamo contare rispetto ad una sola condizione ci basta il conta se, quando abbiamo due o più condizioni dobbiamo utilizzare il conta.più.se.

Sono entrambe funzioni statistiche.

Esempio pratico Conta.più.se

Subito un esempio pratico in excel per applicare entrambe le funzioni!

Partiamo dal classico elenco di vini.

Vogliamo calcolare delle statistiche riassuntive, in particolare vogliamo sapere:
1) quanti vini rossi ci sono in cantina?
2) quanti vini rossi della Sicilia ci sono in cantina?

elenco caso pratico conta più se

La domanda 1) ci richiede di verificare UNA condizione (tipologia del vino -> “rosso”) quindi usiamo il CONTA.SE

La domanda 2) ci richiede di verificare DUE condizioni (tipologia -> “rosso” e regione -> Sicilia) quindi usiamo il CONTA.PIÙ.SE

N° vini rossi -> =CONTA.SE(C9:C73;”rosso”)
N° vini rossi della Sicilia -> =CONTA.PIÙ.SE(C9:C73;”rosso”;D9:D73;”sicilia”)

conta più se

La sintassi del CONTA.SE è quindi =CONTA.SE(intervallo; criterio).

La sintassi del CONTA.PIÙ.SE è non ha solo una coppia intervallo-criterio bensì tante coppie intervallo-criterio (in Excel 2016 fino a 127) =CONTA.PIÙ.SE(Intervallo_criteri1;Criteri1;Intervallo_criteri2;Criteri2;…)

Possiamo scrivere la funzione direttamente nella cella oppure visualizzare l’elenco delle funzioni, posizionarsi sulla categoria di funzioni statistiche

funzioni statistiche

dove è possibile scegliere il CONTA.PIÙ.SE

finestra parametri conta piu se

Condizioni su numeri tra doppi apici

Quando definiamo condizioni su numeri o date utilizzando i simboli di maggiore e minore è necessario racchiudere la condizione tra doppi apici, cosa da ricordare soprattutto se scriviamo la funzione invece che utilizzare la finestra dei parametri.

Scriviamo quindi =CONTA.PIÙ.SE(C9:C73;”rosso”;F9:F73;”>40″).

Se cerchiamo un solo valore possiamo scrivere
=CONTA.PIÙ.SE(C9:C73;”rosso”;F9:F73;40)
oppure
=CONTA.PIÙ.SE(C9:C73;”rosso”;F9:F73;“40”)

esempio criterio numerico

Contare quando ci sono spazi

Quando ci sono spazi possiamo potenziare la funzione conta.più.se con i caratteri jolly.

Scrivere
=CONTA.PIÙ.SE(C9:C73;”*rosso*“;D9:D73;”sicilia”)
significa specificare che la parola “rosso” può essere preceduta e/o seguita da spazi o da altri caratteri. L’asterisco sta per “da zero a un numero qualsiasi di spazi/lettere/numeri”.

Scrivere
=CONTA.PIÙ.SE(C9:C73;”ross?“;D9:D73;”sicilia”)
significa che nella prima condizione cerchiamo tutte le celle in cui la tipolgia è “rosso” oppure “rossa” oppure “rossi” opure “ross” con spazio finale. Il punto di domanda indica la presenza di un elemento (spazio/numero/lettera).

Con questa logica scrivere
=CONTA.PIÙ.SE(C9:C73;”rosso”;D9:D73;“?????”)
significa che nella seconda condizione cerchiamo nell’intervallo D9:D73 tutte le celle che hanno lunghezza 5 (ad esempio “Lazio”)

condizione lunghezza con i caratteri jolly

Contare con intervalli data

Le date vanno specificate tra doppi apici. Con il conta più se possiamo specificare intervalli di date.

Scrivere
=CONTA.PIÙ.SE(E9:E73;“>=01/10/2016”;E9:E73;“<=31/10/2016")
significa contare quante celle sono comprese nell’intervallo 01/10/2016 / 31/10/2016

Scrivere
=CONTA.PIÙ.SE(E9:E73;”>30/09/2016″;E9:E73;“<"&OGGI())
significa contare quante sono le date comprese tra il 30/09/2016 e la data odierna. Da notare l’utilizzo del simbolo & per concatenare il simbolo “<" e il risultato della funzione OGGI().conta se intervalli date

15 Comments

You can post comments in this post.


  • =CONTA.PIÙ.SE(E9:E73;“>=01/10/2016”;E9:E73;“>”” cosa rappresenta? Scrivendo in questo modo non c’è un errore di sintassi?

    Francesco 2 anni ago Reply


    • Grazie Francesco, hai perfettamente ragione. :-) Errore mio. Ho modificato. Un plauso a te anche per essere arrivato in fondo all’articolo :-) :-) :-)

      samuele 2 anni ago Reply


  • Molto utile, Grazie!

    Pedro 2 anni ago Reply


    • Mi fa piacere che ti sia stato utile. E grazie per avermelo fatto sapere. :-)

      samuele 2 anni ago Reply


  • Ciao, nel criterio è possibile inserire il riferimento di una cella o va necessariamente inserita una parola tra le ” “????

    Andrea Pirrone 1 anno ago Reply


    • Ciao Andrea. Tecnicamente si può inserire il riferimento ad una cella però bisogna fare molta attenzione! Se facciamo riferimento ad una cella dell’elenco bisogna stare attenti ad eventuali modifiche. Anche solo l’applicazione di un ordinamento diverso potrebbe portare un valore diverso nella cella a cui abbiamo fatto riferimento. Ed il risultato della nostra funzione potrebbe cambiare.

      La cella a cui fare riferimento dovrebbe trovarsi in una cella esterna all’elenco.

      samuele 1 anno ago Reply


  • Ciao,
    io ho una tabella con 3 colonne A, B, C
    Devo contare quante celle non nulle sono nella colonna C per la Colonna A = “Pippo”
    Ho scritto :
    Countifs(Foglio A:A;”Pippo”;Foglio C:C; ??????)

    Come la posso indicare la condizione non nulla? Considera che nella colonna C c’è del testo, non dei numeri!

    Grazie infiniteeeeeee

    Elena 1 anno ago Reply


    • Ciao Elena, nel criterio potresti scrivere “<>” che sta per “diverso da vuoto”. Dovrebbe bastare. Fammi sapere.

      samuele 1 anno ago Reply


  • devo contare se la stessa cella in più fogli Excel è vuota/>1 ma non mi prende la formula =CONTA.SE(‘01.03.19:30.03.19’!C7;“>1”) dov’è l’errore?
    grazie 1000
    Antonio

    Antonio Caputo 1 anno ago Reply


  • Ciao, sono arrivato al tuo articolo mentre ero alla disperata ricerca di una soluzione al mio problema.
    Forse tu sai aiutarmi:

    Utilizzo la formula:
    =SE(CONTA.PIÙ.SE($C7;”>=01/01/2020″;$C7;”<=31/01/2020")=1;$U7;"")
    per contare la severità di un reclamo in un file annuale. Tutto questo è in una colonna mensile per cui alla fine a Gennaio avrò la somma delle severità di Gennaio.

    Il mio problema è che per qualche motivo la formula non restituisce alcun risultato fino a quando non ci vado sopra dalla barra di inserimento e do INVIO. Non è disattivato il calcolo automatico, infatti tutte le altre funzionano.

    Potrebbe esserci qualche errore di sintassi che manda excel in confusione? Grazie per l'aiuto.

    Andrea 2 mesi ago Reply


    • Ciao Andrea.

      Potrebbe essere un problema di formato cella? Era testuale, ci hai scritto dentro, hai modificato in ‘Generale’ o ‘Numero’ e così quando dai invio recepisce il nuovo formato… Il dubbio però è che, se così fosse, ti dovrebbe mostrare la formula “testuale” inizialmente, non ‘alcun risultato’.

      Se vuoi mandami uno stralcio del file… samuele@amicoexcel.it

      samuele 2 mesi ago Reply


  • ho un quesito, e non so se sto usando la formula giusta, devo fare una tabella di valutazione fornitori, dove avrò 3 colonne una SI dove è soddisfatta la richieste, una no dove non è soddisfatta e una terza colonna “con riserva” in questo caso il fornitore deve fornire ulteriore documentazione, se nella prima colonna sono tutti si allora in una cella a parte uscirà un valore ” accettato” e il campo in verde, se tutti no “non accettato” e il capo rosso e la terza colonna con riserva “da verificare” in giallo vorrei partire da una cosa così per poi implementarla con il peso di alcune celle…..
    Grazie

    Andrea Crovetto 3 settimane ago Reply


    • Ciao Andrea,

      secondo me dovresti verificare se il numero di SI è uguale al numero di celle compilate di quella colonna.
      Esempio:
      =CONTA.SE(A2:A100;”SI”)=CONTA.VALORI(A2:A100)
      ed utilizzare il risultato (vero o falso) di questa uguaglianza all’interno di un SE
      =SE(CONTA.SE(A2:A100;”SI”)=CONTA.VALORI(A2:A100);”accettato”).

      Nella cella poi definisci una semplice formattazione condizionale… se il valore della cella è uguale a… accettato…. allora colora di verde

      Da ripetere per gli altri valori “non accettato” e “da verificare”.

      samuele 2 settimane ago Reply


  • ciao, un esercizio mi chiede di contare il n. di impiegati nati nel 1964. in tabella le date sono riportate gg/mese/anno nella formula con solo le due cifre finali (73 invece di 1973). Scrivo =CONTA.SE(E4:E309;”….”) non so come dovrei scrivere la data. ho provato in tutti i modi, * e ?. puoi darmi una mano? grazie

    ANNA ULIANA 1 settimana ago Reply


    • Ciao Anna.

      Proverei con un CONTA.PIU’.SE
      CONTA.PIU’.SE(intervallo;”>=01/01/1964″;intervallo;”<=31/12/1964").Anche se non mi è chiaro il tuo riferimento alle due sole cifre finali...

      samuele 1 settimana ago Reply


Inserisci un commento