Posts Tagged Under: trucchi excel

flash fill

Flash fill

samuele agnolin
  • 10 aprile 2017
  • livello: intermedio   2 minuti

Flash fill è una funzionalità che ci permette di inserire automaticamente il contenuto nelle celle sulla base di quello che abbiamo scritto su altre celle.

Il riempimento automatico veloce, disponibile dalla versione 2013, ci consente di risparmiare tanto tempo in alcune situazioni evitando di dover ricorrere a funzioni testuali come STRINGA.ESTRAI, RICERCA, SINISTRA.

Esempi pratici di utilizzo di Flash fill.

 A  Ricaviamo la parte numerica da codici formati da numeri e lettere. (altro…)

Leggi articolo

riempire-automaticamente-celle-vuote

Riempire automaticamente celle vuote in Excel

samuele agnolin
  • 28 giugno 2016
  • livello: intermedio   2 minuti

Dobbiamo riempire automaticamente celle vuote inserendo il contenuto della cella superiore? Abbiamo dimenticato di usare il comando “Ripeti tutte le etichette elementi” prima di convertire una tabella pivot in intervallo normale?

Possiamo velocemente sistemare il problema delle celle vuote utilizzando “Vai a formato speciale” e CTRL+INVIO.

Questo il punto di partenza:

celle vuote

Questo il risultato da ottenere:

risultato finale celle piene




Vediamo subito i passaggi necessari per portare il contenuto della cella piena su quelle vuote sottostanti.

 A  Si seleziona l’area contenente le celle da riempire. Con il mouse o con la tastiera (CTRL+SHIFT+barra spaziatrice)

selezione tabella

 B  Si selezionano solo le celle vuote, (altro…)

Leggi articolo

convertire testo in numero

Convertire testo in numero: le 5 soluzioni!

samuele agnolin
  • 2 giugno 2016
  • livello: base   3 minuti

Numeri memorizzati come testo? Il nostro cerca.vert non funziona perché i numeri che confrontiamo sono salvati come testo? Un bel problema ma facilmente risolvibile!

Vediamo assieme 5 veloci modi per convertire testo in numero.

Partiremo sempre dall’esempio mostrato nella seguente immagine. Nella colonna B il numero viene estratto con la funzione testuale DESTRA, la quale restituisce il numero in formato testo. L’allineamento a sinistra, tipico delle celle testuali, già ci fa capire che è effettivamente un testo. Nella colonna C la funzione informativa TIPO ci conferma che il risultato della funzione DESTRA è testuale.

problema testo come numero

Non è possibile convertire cambiando semplicemente il formato della cella? (altro…)

Leggi articolo

formule funzioni excel tre regole d'oro

Formule e Funzioni Excel: 3 regole d’oro!

samuele agnolin
  • 10 aprile 2016
  • livello: intermedio   3 minuti

Sai già scrivere una formula o utilizzare le funzioni di Excel? Bene, prova a vedere se conosci anche queste tre regole d’oro, 3 trucchetti di excel utili a velocizzare il lavoro.

1. Tasto F9 e combinazione CTRL+Z

2. Combinazione CTRL+Backspace

3. Doppio clic sul quadratino di riempimento + utilizzo dei bordi delle celle

1. Tasto F9 e combinazione CTRL+Z

Se in excel scriviamo funzioni annidate o utilizziamo forme matriciali può capitare di avere delle scritture complesse:
un SE ed una E annidati
oppure
una forma matriciale con una SOMMA e un SE => =SOMMA(SE(G6:G847>2011;1;0)).

Come fare per verificare la correttezza delle funzioni o per trovare un eventuale errore segnalato da excel?
Ci viene in soccorso il tasto F9, il quale riesce a mostrarci il risultato di una parte della nostra funzione.

Prendiamo come esempio la seguente funzione in forma matriciale =SOMMA(SE(G6:G847>2011;1;0)).

I passaggi necessari saranno i seguenti:

 A  Clicchiamo due volte all’interno della cella e selezioniamo solamente la funzione SE

funzione matriciale selezione
(altro…)

Leggi articolo

problema data mancano separatori

Problema data: mancano i separatori!

samuele agnolin
  • 13 giugno 2016
  • livello: intermedio   2 minuti

Un campo che rappresenta una data è stato salvato con giorno, mese ed anno consecutivi, senza separatore: ad esempio 30072016. Come fare per ottenere la data scritta nella maniera corretta 30/07/2016?

Esistono più modi per convertire una data di excel scritta senza segno di separatore.

Metodo n°1: funzionalità testo in colonne

Il metodo più semplice consiste nell’utilizzare la funzionalità testo in colonne.

In uno dei passaggi possiamo scegliere di convertire un campo in data, scegliendo il formato GMA, giorno mese anno.

I passaggi sono i seguenti:

 A  Si selezionano i dati da convertire

 B  Ci si posiziona sulla scheda Dati e si sceglie “Testo in colonne”
(altro…)

Leggi articolo

copia-veloce-foglio-excel

Come copiare un foglio di Excel? Un metodo veloce!

samuele agnolin
  • 4 maggio 2016
  • livello: base   2 minuti

Come fai quando hai bisogno di creare una copia di un foglio di lavoro all’interno del file su cui stai lavorando?

Di certo non utilizzi “Sposta o copia..” Ehmm, Ehmmm… vero che non lo utilizzi? No di certo, sono sicuro che infatti non perdi tempo ed utilizzi il metodo veloce CTRL+spostamento del foglio! :-)

Il metodo più veloce: CTRL+spostamento foglio

Per creare una copia di un foglio all’interno dello stesso file su cui si sta lavorando il modo più veloce consiste nello spostamento della linguetta (scheda) del foglio verso destra mentre si tiene premuto il tasto CTRL.

I passaggi sono i seguenti:

 A  Ci si posiziona all’interno del foglio che si vuole copiare. La linguetta in basso sarà quindi più chiara delle altre, ad indicarci che il foglio da copiare è il foglio attivo.

foglio attivo

 B  Si posiziona il cursore sulla linguetta del foglio
(altro…)

Leggi articolo