Se annidati

samuele agnolin
  • 24 ottobre 2016
  • livello: intermedio   2 minuti
se annidati

Nel tutorial sulla funzione SE abbiamo visto diversi esempi su come scrivere la funzione SE quando abbiamo solo un valore da verificare, ad esempio C2<=100.

Come fare quando dobbiamo verificare più valori della stessa colonna? Dobbiamo usare i se annidati, o nidificati. Una funzione SE dentro l’altra.

Nello screenshot più in basso si va a creare una formula che permetta di scrivere “livello basso” nel caso il valore dell’importo sia minore di 50, “livello intermedio” se compreso tra 50 e 100, “livello alto” se maggiore di 100.

La formula finale è la seguente:

=SE(B2<50;”livello basso”;SE(B2<=100;”livello intermedio”;”livello alto”))

se annidati

Il ragionamento chiave per capire l’intera formula è il seguente: il primo Se attribuisce l’etichetta “livello basso” a tutte le righe il cui importo è minore di 50. Quando il test è falso, ossia abbiamo un valore maggiore o uguale a 50, interviene il secondo SE.

Questo vuol dire che excel leggerà il secondo SE solamente quando avremo valori maggiori o uguali a 50. Ecco perché nel secondo SE possiamo “permetterci” di testare solo il caso in cui il valore sia minore o uguale a 100: stiamo infatti verificando così se il valore è >=50 e <=100.

Tecnicamente, la parte fondamentale per la costruzione del SE annidato è quella in cui ci si posiziona nel Se_falso del primo SE e si va a cliccare in alto a sinistra dove c’è la scritta SE (non dovesse esserci il SE è possibile cliccare sulla freccia accanto al nome della funzione scritta e scegliere tra l’elenco o cliccare sulla voce “Altre funzioni…”)

8 Comments

You can post comments in this post.


  • ottimo ,grazie Samuele

    Stefano 11 mesi ago Reply


    • :-) grazie del tuo messaggio

      samuele 11 mesi ago Reply


  • spiegato veramente bene e molto chiaro, con questo ho capito meglio l’argomento, grazie

    Tommaso 9 mesi ago Reply


    • Grazie mille Tommaso!

      samuele 9 mesi ago Reply


  • Chiarissima la spiegazione, ma se dovessi fare un confronto con una striga così ##F81, cosa devo cambiare rispetto alla formula su mostrata?
    Grazie

    Carlo 5 mesi ago Reply


    • Ciao Carlo. Grazie!

      Potrebbe essere =SE(A2=”##F81″; ecc. Quindi se è testuale va fra doppi apici.

      samuele 5 mesi ago Reply


  • Ottimo prodotto.
    si potrebbe invece inserire un dato solo se maggiore o minore di zero, nel senso conteggiare una somma solo se maggiore di zero?

    orazio gentile 5 mesi ago Reply


    • Grazie Orazio.

      Se devi fare una somma solo di numeri maggiori di zero userei il SOMMA.SE. Ad esempio =SOMMA.SE(b2:b10;”>0″).

      Se invece vuoi inserire un numero solo se maggiore di zero, potrebbe essere =SE(B2>0;B2;””)

      Fammi sapere. Ciao. Samuele

      samuele 5 mesi ago Reply


Inserisci un commento