Se annidati

samuele agnolin
  • 24 ottobre 2016
  • livello: intermedio   2 minuti
se annidati

Nel tutorial sulla funzione SE abbiamo visto diversi esempi su come scrivere la funzione SE quando abbiamo solo un valore da verificare, ad esempio C2<=100.

Come fare quando dobbiamo verificare più valori della stessa colonna? Dobbiamo usare i se annidati, o nidificati. Una funzione SE dentro l’altra.

Nello screenshot più in basso si va a creare una formula che permetta di scrivere “livello basso” nel caso il valore dell’importo sia minore di 50, “livello intermedio” se compreso tra 50 e 100, “livello alto” se maggiore di 100.

La formula finale è la seguente:

=SE(B2<50;”livello basso”;SE(B2<=100;”livello intermedio”;”livello alto”))

se annidati




Il ragionamento chiave per capire l’intera formula è il seguente: il primo Se attribuisce l’etichetta “livello basso” a tutte le righe il cui importo è minore di 50. Quando il test è falso, ossia abbiamo un valore maggiore o uguale a 50, interviene il secondo SE.

Questo vuol dire che excel leggerà il secondo SE solamente quando avremo valori maggiori o uguali a 50. Ecco perché nel secondo SE possiamo “permetterci” di testare solo il caso in cui il valore sia minore o uguale a 100: stiamo infatti verificando così se il valore è >=50 e <=100.

Tecnicamente, la parte fondamentale per la costruzione del SE annidato è quella in cui ci si posiziona nel Se_falso del primo SE e si va a cliccare in alto a sinistra dove c’è la scritta SE (non dovesse esserci il SE è possibile cliccare sulla freccia accanto al nome della funzione scritta e scegliere tra l’elenco o cliccare sulla voce “Altre funzioni…”)

Inserisci un commento