come si usa il cerca vert

Cerca verticale: come si usa? (1/10)

samuele agnolin
  • 22 luglio 2016
  • livello: intermedio   3 minuti

Come si scrive il cerca vert? Vediamo subito un esempio pratico. Questo articolo fa parte del tutorial sul cerca verticale.

Abbiamo due elenchi. Il primo è un elenco di clienti che appartengono ad una specifica area geografica. Il secondo è un elenco delle aree geografiche e dei venditori che seguono ogni specifica area.

elenchi per cerca vert

Vogliamo associare ad ogni cliente il rispettivo venditore. Il risultato finale dovrà essere il seguente:

risultato finale cerca vert (altro…)

Leggi articolo

filtro avanzato criteri calcolati

Filtro avanzato oltre ogni limite: i campi calcolati – tutorial 2/2

samuele agnolin
  • 6 luglio 2016
  • livello: avanzato   3 minuti

Vuoi utilizzare il filtro avanzato oltre ogni limite? :-) Bene, in questo articolo vediamo come utilizzare nel modo più “spinto” il filtro avanzato: useremo i campi calcolati!

Nell’articolo dedicato all’utilizzo standard del filtro avanzato abbiamo visto come preparare una tabella dei criteri e come sfruttare i caratteri jolly.

I criteri classici lavorano sulla singola colonna. I criteri o campi calcolati invece ci permettono di valutare più colonne insieme.

I criteri calcolati sono espressioni che noi creiamo e che vengono valutate per ciascuna riga dell’elenco: se l’espressione restituisce VERO allora la riga specifica viene visualizzata, se l’espressione restituisce FALSO la riga viene nascosta.

Impariamo ad usare i criteri calcolati attraverso alcuni esempi. (altro…)

Leggi articolo

problema data mancano separatori

Problema data: mancano i separatori!

samuele agnolin
  • 13 giugno 2016
  • livello: intermedio   2 minuti

Un campo che rappresenta una data è stato salvato con giorno, mese ed anno consecutivi, senza separatore: ad esempio 30072016. Come fare per ottenere la data scritta nella maniera corretta 30/07/2016?

Esistono più modi per convertire una data di excel scritta senza segno di separatore.

Metodo n°1: funzionalità testo in colonne

Il metodo più semplice consiste nell’utilizzare la funzionalità testo in colonne.

In uno dei passaggi possiamo scegliere di convertire un campo in data, scegliendo il formato GMA, giorno mese anno.

I passaggi sono i seguenti:

 A  Si selezionano i dati da convertire

 B  Ci si posiziona sulla scheda Dati e si sceglie “Testo in colonne”
(altro…)

Leggi articolo

conta.se excel

Conta.se excel

samuele agnolin
  • 21 maggio 2016
  • livello: intermedio   5 minuti

Vuoi contare con excel quante volte un particolare prodotto compare in un elenco di acquisti? Quante volte un nome azienda è presente in un elenco di vendite? Il conta se è la funzione che ti serve!

Il CONTA.SE è la funzione di Excel che permette di contare quanti elementi di un dato intervallo rispondono ad un criterio specificato.

Quante volte in un intervallo è presente un particolare codice prodotto, quanti sono gli importi che superano un determinato valore, quante le celle che contengono un testo specificato, quante le date di scadenza inferiori ad oggi.

Il CONTA.SE permette quindi di contare una parte del tutto. Se pensiamo al CONTA.VALORI, funzione che conta quante celle non vuote ci sono in un intervallo, siamo un gradino più in alto in termini di risultati ottenibili e di complessità della formula.

Conta.se come si scrive

La sintassi della funzione, che appartiene alla categoria STATISTICHE, è la seguente:
=CONTA.SE(intervallo;criterio)
Il che equivale a =CONTA.SE(dove_cercare;che_cosa_cercare)

L’intervallo è l’insieme di celle su cui vogliamo andare a contare.
Il criterio è la condizione che la singola cella deve soddisfare per essere conteggiata.

Se ho un elenco in cui voglio contare quante volte compare il prodotto AX250 nell’intervallo B2:B1000 scrivo:
=CONTA.SE(B2:B1000;”AX250″)

Se voglio sapere quante

Leggi articolo

eliminare duplicati

Eliminare duplicati

samuele agnolin
  • 15 luglio 2016
  • livello: base   2 minuti

Devi eliminare duplicati da una tabella excel? La funzionalità Rimuovi duplicati ti permette di farlo in pochissimi secondi. Questo strumento è disponibile dalla versione 2007 di Excel e permette di eliminare doppioni in maniera molto rapida.

Il rimuovi duplicati è utile non solo nel caso si voglia eliminare righe doppie su una tabella ma anche quando è necessario creare un elenco di valori univoci da visualizzare in un menu a tendina in excel.

Vediamo subito i passaggi per rimuovere i duplicati in un elenco di Excel. (altro…)

Leggi articolo

cerca vert con carattere jolly asterisco

Perchè il cerca vert non funziona? Il problema degli spazi

samuele agnolin
  • 30 giugno 2016
  • livello: intermedio   2 minuti

Abbiamo scritto correttamente tutti i parametri del nostro cerca verticale ma otteniamo #N/D. Perché? A volte è un problema di spazi…

Vediamo subito un esempio.

Questa la tabella di partenza:

situazione di partenza per cerca vert

E questo il risultato che vogliamo ottenere.

soluzione finale con cerca vert corretto

Iniziamo scrivendo il nostro cerca verticale. Se hai qualche dubbio sui parametri da utilizzare puoi leggere il capitolo 1 del tutorial relativo a come si usa il cerca verticale.
(altro…)

Leggi articolo

riempire-automaticamente-celle-vuote

Riempire automaticamente celle vuote in Excel

samuele agnolin
  • 28 giugno 2016
  • livello: intermedio   2 minuti

Dobbiamo riempire automaticamente celle vuote inserendo il contenuto della cella superiore? Abbiamo dimenticato di usare il comando “Ripeti tutte le etichette elementi” prima di convertire una tabella pivot in intervallo normale?

Possiamo velocemente sistemare il problema delle celle vuote utilizzando “Vai a formato speciale” e CTRL+INVIO.

Questo il punto di partenza:

celle vuote

Questo il risultato da ottenere:

risultato finale celle piene




Vediamo subito i passaggi necessari per portare il contenuto della cella piena su quelle vuote sottostanti.

 A  Si seleziona l’area contenente le celle da riempire. Con il mouse o con la tastiera (CTRL+SHIFT+barra spaziatrice)

selezione tabella

 B  Si selezionano solo le celle vuote, (altro…)

Leggi articolo

convertire testo in numero

Convertire testo in numero: le 5 soluzioni!

samuele agnolin
  • 2 giugno 2016
  • livello: base   3 minuti

Numeri memorizzati come testo? Il nostro cerca.vert non funziona perché i numeri che confrontiamo sono salvati come testo? Un bel problema ma facilmente risolvibile!

Vediamo assieme 5 veloci modi per convertire testo in numero.

Partiremo sempre dall’esempio mostrato nella seguente immagine. Nella colonna B il numero viene estratto con la funzione testuale DESTRA, la quale restituisce il numero in formato testo. L’allineamento a sinistra, tipico delle celle testuali, già ci fa capire che è effettivamente un testo. Nella colonna C la funzione informativa TIPO ci conferma che il risultato della funzione DESTRA è testuale.

problema testo come numero

Non è possibile convertire cambiando semplicemente il formato della cella? (altro…)

Leggi articolo

Concatena excel

samuele agnolin
  • 11 maggio 2016
  • livello: base   3 minuti

Hai bisogno di concatenare in un’unica cella il contenuto di più celle? Vuoi unire in una cella il nome e cognome dei clienti, scritti su due diverse colonne?

Il simbolo & (e commerciale – sopra il tasto 6) permette di unire il contenuto di più celle in maniera ancor più semplice della funzione CONCATENA. Ad esempio =A4&B4 concatena in un unica cella il contenuto di A4 e B4

Come concatenare in excel il contenuto di più celle

Partiamo da un esempio pratico.

Abbiamo un elenco dei giocatori del Leicester City campioni di Inghilterra 2015/2016. Nome e cognome sono inseriti in due colonne separate. Vogliamo unire nome e cognome in una terza colonna, separandoli con uno spazio.

Il risultato finale dovrà essere questo:

risultato concatena




I passaggi da seguire sono i seguenti:

 A  Nella cella in cui vogliamo unire il contenuto di più celle inseriamo il simbolo di uguale, esattamente come facciamo

Leggi articolo