Funzioni Excel

samuele agnolin
  • 20 marzo 2017
  • livello: base   3 minuti

Le funzioni di Excel sono delle formule predefinite che eseguono calcoli od estraggono informazioni sulla base di parametri da noi definiti. Le funzioni sono suddivise in categorie (ad esempio Matematiche, Statistiche, Testo, Logiche, Data e ora, Ricerca e riferimento). Le funzioni sono 400 circa, il numero esatto varia a seconda della versione.

In questo tutorial vediamo qual è la struttura di una funzione e qual è un elenco di funzioni essenziali da conoscere.



Struttura delle funzioni

Tutte le funzioni hanno questa struttura:
=nome_funzione(parametri)
Esempi: =SOMMA(A1:A100), =SE(A1>100;“Alto”;“Basso”), CERCA.VERT(B4;A10:F99;2;0)

Il numero di parametri varia da funzione a funzione. I parametri possono essere obbligatori o facoltativi e sono divisi da punto e virgola.

Vuoi un elenco delle funzioni di Excel più utilizzate? Queste sono a mio avviso le funzioni che dovremmo assolutamente conoscere:

1) Funzioni base

SOMMA
Somma i numeri presenti in uno o più intervalli

  • Categoria: Matematiche e trigonometriche
  • Sintassi: =SOMMA(intervallo1;intervallo2;ecc.)
  • Esempio: =SOMMA(A1:A1OO)
  • Note: In questa funzione, come nelle altre funzioni base, in caso di più intervalli si utilizza il punto e virgola tra un parametro e l’altro: =SOMMA(A1:A1O;A120:A1000;B1) Somma da A1 ad A100 + da A120 ad A1000 + B1



CONTA.VALORI
Conta le celle piene di un intervallo, a prescindere che siano testo, numero o valore logico

  • Categoria: Statistiche
  • Sintassi: =CONTA.VALORI(intervallo1;intervallo2;ecc.)
  • Esempio: =CONTA.VALORI(A1:A100)



CONTA.NUMERI
Conta le celle numeriche di uno o più intervalli

  • Categoria: Statistiche
  • Sintassi: =CONTA.NUMERI(intervallo1;intervallo2;ecc.)
  • Esempio: =CONTA.NUMERI(A1:A1OO)



CONTA.VUOTE
Conta le celle vuote di uno o più intervalli

  • Categoria: Statistiche
  • Sintassi: =CONTA.VUOTE(intervallo1;intervallo2;ecc.)
  • Esempio: =CONTA.VUOTE(A1:A1OO)
  • Note: funzione che fa il contrario del CONTA.VALORI



MEDIA
Restituisce la Media aritmetica

  • Categoria: Statistiche
  • Sintassi: =MEDIA(intervallo1;intervallo2;ecc.)
  • Esempio: =MEDIA(A1:A1OO)



MIN
Restituisce il valore minimo

  • Categoria: Statistiche
  • Sintassi: =MIN(intervallo1;intervallo2;ecc.)
  • Esempio: =MIN(A1:A1OO)



MAX
Restituisce il valore massimo

  • Categoria: Statistiche
  • Sintassi: =MAX(intervallo1;intervallo2;ecc.)
  • Esempio: =MAX(A1:A1OO)




2) Funzioni che contano in base a criteri

CONTA.SE
Conta il numero di celle che soddisfano un criterio da noi impostato. Il criterio può essere del tipo “>=200” oppure “Milano”

  • Categoria: Statistiche
  • Sintassi: =CONTA.SE(intervallo;criterio)
  • Esempio: =CONTA.SE(B1:B1OO;”>=200″)
  • Note: per esempi pratici vedi il tutorial su CONTA.SE



CONTA.PIÙ.SE
Conta il numero di celle che soddisfano due o più criteri da noi impostati. I criteri possono essere del tipo “>=200” oppure “Milano”: conta quindi solo le celle che hanno un importo superiore o uguale a 200 e la provincia di residenza uguale a Milano.

  • Categoria: Statistiche
  • Sintassi: =CONTA.PIÙ.SE(intervallo_criteri1;criteri1;intervallo_criteri2;criteri2;…)
  • Esempio: =CONTA.PIÙ.SE(B1:B1OO;”>=200″;C1:C1OO;”Milano”)
  • Note: i parametri sono in sostanza coppie di intervallo/criterio. Per esempi pratici vedi il tutorial sul CONTA.PIÙ.SE.

3) Funzioni che sommano in base a criteri

SOMMA.SE
Somma solo le celle di un intervallo che soddisfano un criterio da noi impostato. Ad esempio somma gli importi solo dei clienti di genere femminile.

  • Categoria: Matematiche e trigonometriche
  • Sintassi: =SOMMA.SE(intervallo;criterio;int_somma)
  • Esempio: =SOMMA.SE(D1:D1OO;”F”;E1:E100)
  • Note: i primi due parametri, esattamente uguali ai due parametri del CONTA.SE, servono per identificare le righe che soddisfano il criterio, il terzo parametro la colonna dove effettuare la somma. Per informazioni più dettagliate vedi il tutorial su SOMMA.SE



SOMMA.PIÙ.SE
Somma solo le celle di un intervallo che soddisfano due o più criteri da noi impostati. Somma gli importi solo dei clienti che sono di genere femminile e che risiedono della provincia di Milano

  • Categoria: Matematiche e trigonometriche
  • Sintassi: =SOMMA.PIÙ.SE(int_somma;intervallo_criteri1;criteri1;intervallo_criteri2;criteri2;…)
  • Esempio: =SOMMA.PIÙ.SE(E1:E100;D1:D1OO;”F”;C1:C1OO;”Milano”;)
  • Note: Da notare che l’intervallo dove sommare qui è il primo parametro mentre nel SOMMA.SE era l’ultimo. Gli altri parametri sono coppie intervallo/criterio utili ad individuare le righe che rispondono al criterio.

4) Funzioni logiche

SE
Permette di valutare una condizione (es. il valore della cella è >100? oppure è maggiore di quello di un’altra cella? oppure è uguale ad un determinato testo?) e di compiere un’azione (scrivere un testo od eseguire un calcolo) se la condizione è vera, di compiere un’altra azione se la condizione è falsa

  • Categoria: Logiche
  • Sintassi: =SE(test;se_vero;se_falso)
  • Esempio: =SE(D1=”F”;”Donna”;”Uomo”) restituisce Donna se D1 è uguale a “F” altrimenti restituisce Uomo
  • Note: Per casi pratici vai al tutorial sulla funzione SE



E
Valuta più condizioni e restituisce VERO se tutte le condizioni sono verificate.

  • Categoria: Logiche
  • Sintassi: =E(condizione1;condizione2;…)
  • Esempio: =E(D1=”F”;C1=”Milano”) restituisce VERO se la cella D1 è uguale ad “F” e la cella C1 è uguale a “Milano”
  • Note: Questa funzione è usata spesso nel test della funzione SE per fare in modo che la funzione SE possa valutare più di una condizione. Si veda il tutorial sulla funzione E.



O
Valuta più condizioni e restituisce VERO se almeno una condizione è verificata.

  • Categoria: Logiche
  • Sintassi: =O(condizione1;condizione2;…)
  • Esempio: =O(D1=”F”;C1=”Milano”) restituisce VERO se la cella D1 è uguale ad “F” oppure se la cella C1 è uguale a “Milano”



SE.ERRORE
Restituisce un valore da noi definito nel caso la cella sia costituita da un errore, altrimenti restituisce il valore della cella

  • Categoria: Logiche
  • Sintassi: =SE.ERRORE(valore;valore_se_errore)
  • Esempio: =SE.ERRORE(A1;”prodotto non disponibile”) restituisce “prodotto non disponibile” se A1 è un errore altrimenti restituisce il valore di A1
  • Note: Spesso usata assime al CERCA.VERT per personalizzare il messaggio di errore #N/D




5) CERCA.VERT

CERCA.VERT
Cerca un determinato valore (numerico o testuale) nella prima colonna di un elenco. Una volta trovata la riga che contiente il valore cercato restituisce l’informazione di una precisa colonna della riga trovata.

  • Categoria: Ricerca e riferimento
  • Sintassi: =CERCA.VERT(valore;matrice_tabella;indice;intervallo)
  • Esempio: =CERCA.VERT(F2;A1:G1OO;4;0)
  • Note: Per maggiori informazioni leggi il tutorial su CERCA.VERT

6) La funzione per dati filtrati

SUBTOTALE
Fondamentale quando abbiamo dati filtrati! Applica una funzione di base (SOMMA, CONTA.NUMERI ecc.) su dati filtrati

  • Categoria: Matematiche e trigonometriche
  • Sintassi: =SUBTOTALE(intervallo1;[eventuale_riferimento])
  • Esempio: =SUBTOTALE(9;A1:A1OO) effettua la somma sull’intervallo filtrato A1:A100
  • Note: il parametro che ho chiamato [eventuale_riferimento] serve in caso di scelta di funzione GRANDE o PICCOLO

7) Funzioni testuali

STRINGA.ESTRAI
Estrae un numero definito di caratteri a partire da una determinata posizione

  • Categoria: Testo
  • Sintassi: =STRINGA.ESTRAI(testo;inizio;num_caratt)
  • Esempio: =STRINGA.ESTRAI(A1;4;3) restituisce tre caratteri a partire dal quarto della cella A1
  • Note: Per ulteriori informazioni vedi il tutorial STRINGA.ESTRAI. Quando si estrae un numero questo è visto come testo. Può essere utile convertire un numero testuale in numero.



SINISTRA
Restituisce un numero definito di caratteri da una strina a partire da sinistra

  • Categoria: Testo
  • Sintassi: =SINISTRA(testo;num_caratt)
  • Esempio: =SINISTRA(A1;4) restituisce i primi quattro caratteri della cella A1



DESTRA
Restituisce un numero definito di caratteri da una strina a partire da destra

  • Categoria: Testo
  • Sintassi: =DESTRA(testo;num_caratt)
  • Esempio: =DESTRA(A1;4) restituisce gli ultimi quattro caratteri della cella A1



LUNGHEZZA
Restituisce il numero di caratteri di una stringa di testo (spazi compresi)

  • Categoria: Testo
  • Sintassi: =LUNGHEZZA(testo)
  • Esempio: =LUNGHEZZA(A1)



ANNULLA.SPAZI
Elimina gli spazi iniziali e finali da una stringa. Se trova più spazi tra le parole della cella ne lascia uno solo.

  • Categoria: Testo
  • Sintassi: =ANNULLA.SPAZI(testo)
  • Esempio: =ANNULLA.SPAZI(A1)
  • Note: Utile quando abbiamo spazi in più che ci creano problemi nell’utilizzo di altre funzioni, come ad esempio il CERCA.VERT



RICERCA
Cerca un testo all’interno di una stringa di testo e restituisce la posizione in cui è presente il testo

  • Categoria: Testo
  • Sintassi: =RICERCA(testo;stringa;[inizio])
  • Esempio: =RICERCA(“shop”;A1) restistuisce la posizione di shop nel contenuto della cella A1
  • Note: in caso di testo non presente nella stringa viene restituito l’errore #VALORE!

8) Funzioni Informative

Le funzioni informative sono utilissime quando dobbiamo intercettare errori oppure sapere se una particolare cella è vista da Excel come numerica o testuale.

TIPO
Restituisce un numero a seconda della tipologia della cella. I due risultati più utili sono: 1 se la cella è considerata numero, 2 se testo. Funzione molto utile per stabilire con certezza come una cella viene vista da Excel.



VAL.NUMERO
Restituisce VERO se il valore analizzato è numerico

  • Categoria: Informative
  • Sintassi: =VAL.NUMERO(valore)
  • Esempio: =VAL.NUMERO(A1)
  • Note: Funzione utilizzata spesso assieme alla funzione SE



VAL.TESTO
Restituisce VERO se il valore analizzato è testuale

  • Categoria: Informative
  • Sintassi: =VAL.TESTO(valore)
  • Esempio: =VAL.TESTO(A1)
  • Note: Funzione utilizzata spesso assieme alla funzione SE



VAL.ERRORE
Restituisce VERO se il valore analizzato è un errore

  • Categoria: Informative
  • Sintassi: =VAL.ERRORE(valore)
  • Esempio: =VAL.ERRORE(A1)
  • Note: Funzione utilizzata spesso assieme alla funzione SE



VAL.NON.DISP
Restituisce VERO se il valore analizzato è un errore #N/D, tipico errore restituito dalla funzione CERCA.VERT quando il valore cercato non è stato trovato

  • Categoria: Informative
  • Sintassi: =VAL.NON.DISP(valore)
  • Esempio: =VAL.NON.DISP(A1)
  • Note: Funzione utilizzata spesso assieme alle funzioni SE e CERCA.VERT


9) Funzioni Data e ora

ADESSO
Restituisce la data e l’ora correnti

  • Sintassi: =ADESSO()
  • Note: Non sono previsti parametri



OGGI
Restituisce la data corrente

  • Sintassi: =OGGI()
  • Note: Non sono previsti parametri



DATA
Restituisce una data a partire da tre numeri che rapprensentano anno, mese e giorno

  • Sintassi: =DATA(Anno;Mese;Giorno)
  • Esempio: =DATA(2017;10;01) Restituisce la data 01/10/2017. Se viene restituito il numero corrispondente (in questo caso 43009) è sufficiente modificare il formato cella in Data
  • Note:

Inserisci un commento