Funzione SE

samuele agnolin
  • 17 ottobre 2016
  • livello: intermedio   3 minuti

La funzione SE ci permette di valutare il contenuto di una cella e di prendere di conseguenza una decisione.

Se la cella con la quantità a magazzino è minore o uguale a 1000 voglio scrivere “Prodotto da riordinare” altrimenti scrivo “Scorta sufficiente”.

funzione se

La funzione SE è quindi concettualmente per noi tutti molto intuitiva. Applica infatti un ragionamento che facciamo 100 volte al giorno. Valutiamo una situazione e di conseguenza facciamo una scelta:

Se c’è il sole utilizzo la bici altrimenti prendo la macchina. Se leggo fino in fondo questo breve tutorial imparo bene la funzione SE altrimenti no. :-)


 



Come si scrive la funzione SE?

La funzione SE va scritta in una singola cella. Spesso poi la cella è la prima di un elenco quindi essa viene trascinata verso il basso su tutte le righe dell’elenco.

Ecco come va scritta la funzione SE:

=SE(E2<=100;”Basso”;”Alto”)

funzone se sintassi

La funzione SE richiede tre parametri:

– il Test (obbligatorio): è una espressione che chiediamo ad Excel di valutare, in questo caso chiediamo se il valore della cella E2 è minore o uguale a 100

– il Se_vero (facoltativo): quel che vogliamo far fare a Excel quando il test è vero. Nell’esempio vogliamo scrivere “Basso” ma, come vedremo negli altri esempi di questo tutorial, a volte potremmo voler far eseguire un calcolo invece che far scrivere un testo/numero/data

– il Se_falso (facoltativo): su questo parametro excel “arriva” quanto il test è falso, nel nostro caso quanto è falso che E2 è minore o uguale a 100, quindi quando E2 è maggiore di 100. Per questo facciamo scrivere “Alto”

Questo il risultato finale:

risultato finale funione logica se

Quando Se_vero o Se_falso non vengono specificati il risultato sarà uno dei due valori logici VERO o FALSO.

Se preferiamo inserire il SE utilizzando la finestra di inserimento dei parametri questi sono i passaggi:

 1  ci si posiziona sulla cella dove si vuole il risultato

 2  si clicca sul tastino Fx di inserimento funzioni e nella tipologia Logiche si sceglie il SE
finestra funzioni logiche

 3  si definiscono il test e i parametri Se_vero e Se_falso

finestra funzione se




Il SE appartiene alle funzioni logiche ed è tra le più utilizzate tra tutte le funzioni. Si presta, infatti, a risolvere tantissime situazioni che richiedo una verifica di una situazione.

Casi pratici funzione SE

Ecco alcune casi pratici di utilizzo della funzione SE.

Esempio 1. Vogliamo scrivere “Donna” quando la cella del genere riporta “F”, “Uomo” altrimenti.

=SE(B2=”f”;”Donna”;”Uomo”)

esempio pratico funzione se uguale a

che potrebbe anche essere scritta in questo modo:

=SE(B2<>”f”;”Uomo”;”Donna”)
dove <>”f” significa diverso da “f”

esempio pratico funzione se diverso da

Esempio 2. Vogliamo calcolare un importo scontato applicando uno sconto del 5% se il cliente ha speso meno di 100 euro, del 10% se ha speso da 100 in su.

=SE(B2<100;B2*0,95;B2*0,9)

caso pratico se sconto

Esempio 3. Vogliamo nascondere temporaneamente il risultato di una formula. Nell’esempio qui sotto viene calcolata la somma cumulata degli importi aggiungendo il valore del singolo mese alla somma dei mesi precedenti.

La formula se senza restituisce un valore fuorviante:

caso pratico formula da nascondere

Possiamo aggiustare inserendo un SE per far sapere ad Excel che vogliamo che visualizzi la somma cumulata solo per i mesi per cui abbiamo già il valore dell’importo:

=SE(B3<>””;B3+C2;””)

caso pratico formula nascosta con se

Esempio 4. Vogliamo verificare la correttezza dei codici prodotto. Se la lunghezza del codice è pari a 9 il codice ha un numero esatto di cifre altrimenti segnaliamo che il codice è errato.

=SE(LUNGHEZZA(B2)=9;”ok”;”codice errato”)

esempio pratico funzione lunghezza

Esempio 5. Se le ultime lettere del codice prodotto sono “FFF” allora noi sappiamo che il prodotto è una sedia, altrimenti è un tavolo.

=SE(DESTRA(B2;3)=”fff”;”sedia”;”tavolo”)
esempio pratico funzione destra testuale

Attenzione però che se avessimo un codice con tre numeri finali dovremmo ricordare comunque che la funzione DESTRA restituisce un risultato testuale. Quindi andrebbe scritta in questo modo:

=SE(DESTRA(B2;2)=”40″;”sedia”;”tavolo”)

oppure in questo modo:

=SE(- -DESTRA(B2;2)=40;”sedia”;”tavolo”)
dove il – – davanti alla funzione DESTRA converte il risultato di destra in numerico

esempio pratico funzione destra trasformata in numero

Il modo errato sarebbe: =SE(DESTRA(B2;2)=40;”sedia”;”tavolo”)

esempio pratico funzione destra non trasformata errato

Esempio 6. La funzione SE può essere utilizzata anche in combinata con il cerca verticale. E in più modi:

– per richiamare un cerca vert piuttosto che un altro
=SE(B2<100;CERCA.VERT(B2;K1:N500;2;0);CERCA.VERT(B2;P1:S500;3;0))

– per modificare in maniera dinamica il riferimento alla matrice tabella
=CERCA.VERT(B2;SE(B2<100;K1:N500;P1:S500);2;0)

Funzione SE con date

Quando utilizziamo nella funzione se una data, può capitare di trovarci di fronte ad una data memorizzata come testo, cosa che può succedere ad esempio quando il file è una estrapolazione da un database. In questo caso dobbiamo convertire la data testuale attraverso la funzione DATA.VALORE, la quale converte una data in formato testo in un numero quindi una data, come ci dice anche la guida ufficiale.

=SE(B2<DATA.VALORE(“1/1/2016”);”Pre 2016″;”2016 o successivo”)

funzione se data

Se la data è in formato numerico/data possiamo invece scrivere: =SE(B2<1/1/2016;”Pre 2016″;”2016 o successivo”)

Chiaramente potremmo fare riferimento senza problemi ad una data scritta in una cella esterna:

=SE(B2<G$1;”Pre 2016″;”2016 o successivo”)

funzione se data con cella esterna

Se hai trovato interessante questo tutorial sulla funzione SE forse ti può interessare anche il tutorial sui SE ANNIDATI :-)

tutorial se annidati

3 Comments

You can post comments in this post.


  • Complimenti, molto chiaro. Ho ricreato gli esempi ed è andato tutto bene. Stavo però facendo alcune prove e mi sono imbattuto in un dubbio che non riesco a risolvere. Ho creato una funzione SE la quale mi restituisce dei valori numerici in base al contenuto testuale che inserisco in determinate celle. Se poi però vado a sommare ( con la semplice funzione SOMMA ) i valori numerici ottenuti con la funzione SE, mi restituisce sempre 0. Potrebbe darmni qualche suggerimento? non capisco cosa stia sbagliando. Grazie mille

    Antonello 2 mesi ago Reply


  • Ciao Samuele,
    ti ringrazio per le spiegazioni che sono sempre molto esaustive.
    Ti chiedo però di darmi una mano ulteriore per risolvere un caso che ho visto non hai trattato (spero non mi sia sfuggito).
    Prendiamo il caso del primo esempio che hai presentato dopo il titolo “Come si scrive la funzione SE?”. Io ho un caso simile ma devo differenziare ulteriormente il risultato se la spesa è stata fatta da una donna o se è stata fatta da un uomo. Cioè specificare che se la spesa è stata fatta da una donna deve darmi come risultato “Basso” se <100 se è stata fatta da un uomo deve darmi come risultato "Basso" se <90.
    Sono un insegnante di educazione fisica è ho bisogno di valutare i miei ragazzi con parametri diversi se sono maschi o femmine. Uso la formula SE per specificare che da un dato risultato ad un altro mi deve dare valore 6, poi 7 e così via. Purtroppo però non riesco a diversificare ulteriormente in base al sesso.
    Ti prego di aiutarmi.
    Grazie
    Toni

    Toni 2 mesi ago Reply


    • Ciao Toni, io penso che dovresti utilizzare due se annidati oppure una funzione E all’interno della funzione SE.

      Qualcosa tipo: =SE(A2=”F”;SE(B2<100;"Basso";"Alto");SE(B2<90;"Basso";"Alto")) -> il secondo SE viene letto solo quando A2 non è F

      Se cmq vuoi inviarmi uno stralcio del tuo file, senza dati sensibili ovviamente, fai pure: samuele@amicoexcel.it

      samuele 2 mesi ago Reply


Inserisci un commento